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A native macOS application that converts mixing sessions between Avid Pro Tools (.ptx) and Cockos Reaper 

(.rpp) in both directions. Runs entirely on the Mac — no Wine, no virtual machine, no Pro Tools licence required. 

Available as a standalone app from filmsound.ai (direct DMG, includes a Reaper extension) or from the Mac App 

Store (sandboxed, no extension). Both builds perform the same conversion.

Quick start
1. Drop a .ptx or .rpp file onto the input slot, or use Browse. The converter auto-detects direction from the 

extension.

2. Pick an Output mode — Link to source (light, references originals) or Copy Media (Standalone) (self-

contained bundle). The output path preview updates underneath.

3. Click the funnel icon to filter what gets converted (automation, playlists, markers — defaults convert 

everything). Click the gear in the top-right corner to customise default folder names for processed audio / 

video files (used in both Link and Standalone modes; in Link mode for any derivatives the converter has to 

create, in Standalone for everything copied into the bundle).

4. Click Convert. The output file appears in the chosen folder, ready to open in the destination DAW.

Trial and licence
The unlicenced (Trial) build trims clips, fades and automation past the first two minutes from the earliest clip. Track 

count, bus structure, routing, channel layout, panning, markers and tempo are not limited — you see the full session 

structure even in Trial, just with shortened audio.

Activation works differently depending on where you got the app:

• Direct DMG. Open the licence sheet (the Activate License button at the bottom of the main window), paste 

the key you received by email after purchase on filmsound.ai, and click Activate. The key is tied to your 

machine and is verified online once; afterwards the app runs offline.

• Mac App Store. The purchase is handled by Apple — there is no licence-key field. After buying through the 

in-app Buy button, the app is licensed for any Mac signed in with the same Apple ID.

If you bought through the App Store but later switch to the Direct DMG (e.g. to get the Reaper extension), open the 

licence sheet and click Restore Purchase — the Direct app will detect your existing App Store purchase via Apple 

and activate without needing a key. The reverse direction (Direct purchase, App Store install) is not supported by 

Apple’s StoreKit: re-buy in the App Store if you need the sandboxed build, or just stay on the Direct DMG.

Installation
Direct DMG. The disk image contains four items:

PT Reaper Converter.app Drag onto Applications (the symlink on the right side).

reaper_ptx_import.dylib The Reaper extension. Drag onto REAPER UserPlugins (the alias on the right 

side). The alias points at ~/Library/Application Support/REAPER/UserPlugins/.

If macOS Gatekeeper blocks the first launch (“the developer cannot be verified”), Control-click the app in Applica

tions and choose Open once. From then on it launches normally. The DMG and app are notarized by Apple, so on 

macOS 14+ this prompt should not appear.

If you need to clear quarantine manually: xattr -d com.apple.quarantine "/Applications/PT Reaper 

Converter.app"

Mac App Store. Install like any other app. The App Store build is sandboxed and does not include the Reaper 

extension — use the standalone-app workflow (convert in the app, then open the resulting .rpp in Reaper).

Requirements. macOS 14 Sonoma or later. Universal binary — Apple Silicon and Intel. Reaper 6 or later for the 

extension (Reaper 7 recommended for the most accurate fade and lane rendering).
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Reaper extension setup
The extension installs an action, not a File-menu entry. Cockos Reaper does not let third-party extensions modify 

the built-in menus directly, so the entry point is added through Reaper’s Action list — from there you can run it, bind 

a shortcut, or place it in a menu yourself.

1. Quit Reaper completely (menu → Quit Reaper, or ⌘Q) if it was running when you copied the dylib.

2. Re-launch Reaper. Open Actions → Show action list… (default shortcut: ?).

3. In the filter field type PTX. You should see Import PTX Session Data… in the results.

4. Select the action and choose one of:

• Run — executes the action once.

• Add shortcut — bind a keystroke for repeat use.

• Customize menus / toolbars (under the Action list’s gear menu) — add the action to the File, 

Extensions or any custom menu.

If the action does not appear in the list, the extension didn’t load. Check:

• The dylib is in ~/Library/Application Support/REAPER/UserPlugins/. The DMG alias points there, but if you 

dragged it elsewhere by mistake, Reaper won’t find it.

• Reaper was fully quit (not just closed) before the dylib was copied. New extensions are only scanned at 

launch.

• REAPER → About REAPER → Plug-ins lists reaper_ptx_import and shows it as loaded. If it appears with 

an error, send the error text to support.

The standalone app does exactly the same conversion as the extension. The extension is a convenience that skips 

the manual “convert to .rpp, then File → Open” round-trip.

Output mode: Link vs Standalone
Both directions of conversion have the same two file-handling modes, picked via the Link to source / Copy Media 

(Standalone) tabs in the Output section. Both the standalone app and the Reaper extension share this control.

Link to source. The output project references the original files at their current absolute paths; originals are never 

touched. Output is small, no copy step. By default the converter saves the output project right next to the source 

(toggle off “Save in same folder as source” to pick a different folder). The session file name auto-fills from the source 

name and is editable. Pick this for in-house work where the audio doesn’t travel.

Copy Media (Standalone). Self-contained bundle: a new folder named after the source session is created at the 

chosen output path, containing the project file plus an audio sub-folder (defaults: Media/ for Reaper output, Audio 

Files/ for Pro Tools output). On the Pro Tools side the converter stamps an Avid Unique ID into each WAV’s BWF + 

UMID chunk so PT relinks correctly even after the bundle is moved. A separate Copy video files checkbox copies 

video into the bundle too — leave it off (default) for multi-GB clips that can stay on external storage. The bundle 

name auto-fills from the source name and is editable.

Folder names for audio + video are user-configurable — click the gear icon in the top-right corner of the main 

window to set defaults per direction (Pro Tools side: typically Audio Files + Video Files; Reaper side: typically 

Media). These names are used in BOTH modes: in Link mode for any processed derivative files the converter has 

to create (split-mono merges, resamples, transcodes), and in Standalone for everything copied into the bundle. 

Setting audio and video to the same value collapses both into one folder, useful for editors who keep everything 

under Audio Files/. Preferences apply to both the standalone converter and the Reaper extension automatically.

When Standalone is on AND the output folder collides with the source audio folder, the conversion is blocked in 

preflight to prevent overwriting originals; switch to Link mode or pick a different output folder.

Automatic conversions in both modes. Some sources are not directly playable by the destination DAW. The 

converter normalises all of those automatically — you don’t need to toggle anything for it to happen. Converted 

files land in the project’s audio folder regardless of Standalone state; the originals stay untouched.

Both directions Split-mono channel pairs (name.L.wav + name.R.wav) are merged into a single interleaved 

file. The merged file uses the stripped base name (no .L/.R suffix). On the PT side, AIF 

source files are forced to WAV at merge time.

Reaper → PT only Sample-rate mismatches with the session: the file is resampled to the session rate and 

saved with a _sr<kHz> suffix (e.g. kick_sr48.wav for a 44.1 → 48 kHz conversion). Lossy 

and non-native formats (FLAC, OGG, MP3) are transcoded to WAV with a _pt suffix (e.g. 

vox.flac → vox_pt.wav). Reaper plays Pro Tools’ WAV / AIF natively at any rate, so no 

equivalent step is needed in the PT → Reaper direction.

In Standalone mode these conversions happen alongside the verbatim copies of every other file. In Link mode only 

the files that actually needed conversion appear in the output’s audio folder; everything else is referenced in place.
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💡 Get the cleanest Link-mode output

Before converting, consolidate your source audio so that every file is interleaved WAV at the session’s 

sample rate. With nothing to merge, resample or transcode the converter has zero work to do in Link mode 

— no extra files are created, no Audio Files/ / Media/ folder appears next to the output, and the resulting 

project links directly at every original source.

💡 Cleanest Pro Tools → Reaper preparation: Save Copy In

Before converting, let Pro Tools normalise every source file to a single uniform format. In Pro Tools: File → 

Save Copy In…, set Audio File Format to BWF (.WAV), pick one bit depth and one sample rate for the 

whole session, and tick Interleaved (not split-mono). Pro Tools then writes a fresh copy of every audio file 

with a proper WAVEFORMATEXTENSIBLE channel mask for any multichannel material. Point the converter at 

this freshly-saved session. The choice of bit depth or sample rate doesn’t matter — what matters is that Pro 

Tools itself normalises every file in one pass, so Reaper sees a consistent, mask-tagged set of sources with 

no out-of-band quirks left over from imported / older material.

💡 Bounce Reaper item-level processing before converting (Reaper → Pro Tools)

The converter translates timeline / track structure, clip placement, fades, clip gain, clip mute / colours / 

names, track and clip-level pan automation, ReaSurroundPan, and item channel-mode (CHANMODE) 

selection of a single source channel (Mono (Left), Mono (channel N)) or a stereo pair (Stereo 1/2, Stereo 

N/N+1). It does not yet translate per-item processing that lives inside Reaper items — Item FX (per-clip 

plug-in chains), take FX, take envelopes, stretch markers and time-stretching, per-item pitch shift, 

PLAYRATE (item playback rate), Mono (downmix) and Reverse stereo channel modes, reversed items, 

looped items, and multiple takes within one item. Anything in this list is silently dropped or flattened on 

conversion. The clean solution is to bake it into the audio in Reaper first: Item → Glue items (or Render 

items as new take, including take FX) for each affected item, then convert from the glued result. Glue 

freezes every Reaper-specific transform into a fresh WAV, so what Pro Tools sees is exactly what plays back 

in Reaper.

Video. In Standalone mode the Copy video files checkbox controls whether video tracks are copied into the 

bundle’s video folder (default Video Files/, configurable in Preferences) or left referenced at their original path. 

Default off — video is typically multi-GB and the destination DAW can link by absolute path even when video lives 

on an external drive.

Preflight and Relink
Before every conversion the app reads the source session, walks every clip and pool entry, and shows a Preflight 

Report with the session’s vital statistics (sample rate, frame rate, tempo, length, track counts, file counts, Pro Tools 

or Reaper version) and any compatibility warnings: missing audio files, missing video files, unsupported plug-ins, 

mixed-format tracks that will be auto-split, tracks above 12 channels, etc. Nothing is written to disk at this stage 

— you can change settings or cancel without consequences.

If files are reported missing or in the wrong location, click Relink… on the preflight panel to open the Relink dialog. 

The dialog lists every unresolved file and lets you point at its current location on disk (file-by-file or by choosing 

a single replacement folder that the app searches recursively). Resolved files are remembered for this conversion 

only — the source .ptx / .rpp itself is never modified.

This is especially useful when you don’t have a Pro Tools licence at hand: you can take a .ptx from a colleague, 

verify in seconds that every audio and video file is reachable, relink whatever moved between machines, and then 

convert without any “missing media” surprises on the other side. The same applies in the opposite direction — 

checking a .rpp for missing renders / take pools before producing the .ptx avoids silently-incomplete sessions 

reaching Pro Tools.

The Preflight Report also flags structural issues the converter cannot fix automatically — for example a Reaper track 

holding clips in two incompatible channel layouts will be split into separate tracks in Pro Tools, and the preflight 

tells you which tracks and how. Address those in the source DAW before converting if the auto-handling isn’t what 

you want.
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Pro Tools → Reaper
The converter reads the .ptx directly (no AAF or OMF round-trip needed) and emits a .rpp project file. Audio is 

either referenced in place from Pro Tools’ Audio Files folder (Link mode) or copied into a Media/ folder next to 

the .rpp (Standalone mode) — see Standalone vs Link mode above.

What converts

Tracks & clips Audio, Aux Input, Routing Folder, Master and Video tracks. Clips with positions, lengths, 

mute, colours, names.

Fades Fade-ins, fade-outs and crossfades, with the original curve shape preserved (concave / 

linear / convex).

Clip gain Both static dB values and dynamic breakpoint envelopes.

Automation Track Volume, Pan, Mute and send automation (slots A–J).

Routing Output, input and send routing. Sub-path buses (5.0, LCR, LFE). Folder-based routing with 

full nesting.

Surround 5.1, 7.1 and 7.1.2 surround panners as ReaSurroundPan, with both static positions and 

dynamic automation.

Playlists Pro Tools playlists become Reaper Fixed Item Lanes (audio and video).

Timeline Markers (Memory Locations with names and colours), tempo map, time signature changes.

Visual Track colours, clip colours, track notes (via the SWS extension), solo state, solo safe.

Audio files WAV, AIF and RF64. Split-mono pairs (.L/.R) merged into interleaved stereo. Polyphonic files 

use iXML for channel naming.

Routing
Pro Tools’ mixer hierarchy is mapped to Reaper folder tracks: tracks sharing an output bus are grouped under 

a single folder track in the destination project. This handles sub-paths, multi-receiver buses, and nested folders 

faithfully for film and music sessions alike — no user toggle needed.

Reaper → Pro Tools
Conversion in this direction writes a complete Pro Tools session bundle that opens in Pro Tools 11 and later. The 

bundle contains the .ptx, an Audio Files folder, and (if your project uses video) a Video Files folder or a path 

reference to the original.

What converts

Tracks Audio, Folder and Video tracks. Reaper tracks that receive sends are converted as Pro 

Tools Aux Input tracks automatically.

Clips Positions, lengths, mute, colours, names. Fades and crossfades with curve shape 

preserved.

Clip gain Static and dynamic.

Automation Track Volume, Pan, Mute on all converted tracks.

Routing Folder structure with bus auto-creation. Multichannel routing follows the Reaper master / 

parent channel count.

Surround 3.0 / 4.0 / 5.0 / 5.1 / 7.1 / 7.1.2 via ReaSurroundPan, with both static slider positions and 

full automation. For LFE the converter reads the value from the first channel only of the 

Reaper panner and writes it into the Pro Tools panner’s single LFE knob (Pro Tools has 

one LFE control even for stereo sources, so the Right-channel LFE in Reaper is 

intentionally ignored).

Audio & video files See Standalone vs Link mode above. The converter auto-normalises mixed-rate audio, 

FLAC / OGG / MP3 and split-mono pairs in both modes. Video formats actually 

supported by Pro Tools on Mac: .mov, .mp4, .m4v, .mxf.

Timeline Tempo, time signatures, project markers (with names and colours) become Pro Tools 

Memory Locations.
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Visual Track notes, colours, solo state, solo safe.

Preflight Before conversion the app shows a report of incompatible features, missing files and 

warnings. A Relink dialog lets you point at moved sources without touching the project.

Common questions

My Pro Tools mono track came through as 6-channel in Reaper
This is correct. Reaper has no concept of a “mono track” — every Reaper track has at least 2 channels, and any 

track that needs to play out of a 5.1 destination must itself be 6-channel. So when a Pro Tools mono track is routed 

to a 5.1 bus or directly to the 5.1 Main / Control Room output, the converter widens the Reaper track to 6 channels 

and inserts a ReaSurroundPan with the mono input locked to the correct speaker (CR.L, CR.C, CR.LFE, CR.Ls, 

CR.Rs, etc.). The audio plays out of the exact same physical speaker as in the Pro Tools session.

If you wanted the converted Reaper project to play in surround, make sure Reaper’s Preferences → Audio → 

Device output channel count matches your speaker layout (6 for 5.1, 8 for 7.1, etc.) — otherwise Reaper will 

downmix internally and you’ll lose the routing.

Fades sound different from Pro Tools
Since version 1.5.5, fade curve shapes are preserved on both directions of conversion: concave, linear and convex 

slopes for fade-ins, fade-outs and crossfades open in the other DAW with the same audible curvature. Earlier 

versions wrote a generic equal-gain curve regardless of the source, which looked similar on screen but sounded 

flat. Re-convert older sessions with 1.5.5+ to pick up the shape mapping.

The two extreme square-block shapes from Pro Tools’ fade dropdown (top and bottom items) are not produced — 

they’re musically unusable and clamped to the nearest curved shape.

Pro Tools shows my files as “missing” or asks to relink
Two likely causes:

• Source files moved after conversion. If you used Link mode and then moved the converted .ptx to another 

machine or rearranged the source folders, Pro Tools can’t find them — Link mode references files by path. 

Use Standalone mode for portable sessions (it copies the files into the bundle and writes Avid Unique IDs so 

relink works automatically).

• Files were renamed after Standalone conversion. Pro Tools matches Standalone-bundled files by Avid 

Unique ID, not by filename, so the Relink dialog in PT will offer the right candidates and you can confirm one 

by one.

Sample-rate or format mismatches (mixed-rate sources, FLAC / OGG / MP3, split-mono pairs) are not a relink 

cause — the converter normalises all of those automatically in both Standalone and Link modes. Files that need 

conversion are emitted into an Audio Files/ folder next to the .ptx with a _sr<kHz> (resampled) or _pt (transcoded) 

suffix; the originals stay untouched. You don’t need to toggle anything for this to happen.

My video doesn’t open in Pro Tools
Pro Tools on Mac reliably opens .mov, .mp4, .m4v and .mxf (with a supported codec). .avi and .mkv are detected 

as video by the converter — so the track is created correctly — but Pro Tools on Mac cannot decode them. Re-

encode such clips to .mp4 (H.264) or .mov (ProRes) before conversion.

If the video is online and Pro Tools still shows it offline, the file may have a non-standard MP4 layout (moov atom at 

the end of file). Versions 1.5.4 and later handle that case automatically.

“Some clips were trimmed” or boundaries warnings after PT opens my session
The Pro Tools native warning appears when a clip extends beyond the source file’s actual duration. Run the 

converted session through File → Save As… → New copy in Pro Tools once — this re-writes the references using 

PT’s own checks and the warning disappears.

Where do I send a bug report?
In the app: Help → Report a bug… opens a pre-filled email. Or directly to info@filmsound.ai. Please include the 

version (visible in About PT Reaper Converter), a short description of what you expected vs what happened, and 

— ideally — a small reproducer session. Sessions under 25 MB can be attached directly; larger ones via Dropbox / 

Drive / WeTransfer link.
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What is on the roadmap?
Currently surfaced as preflight warnings, planned for upcoming releases: Reaper-side send slots A–J as Pro Tools 

sends, Reaper Fixed Item Lanes / Takes as Pro Tools playlists, Master Fader track conversion, MIDI tracks and clips 

(both directions), full plug-in chain conversion (only ReaSurroundPan converts today), Atmos extended surround 

formats (5.1.2, 5.1.4, 7.1.4, 7.1.6, 9.1.4, 9.1.6), tick-based / beat-locked tracks, and per-track options to skip or 

keep inactive and hidden tracks.

PT Reaper Converter is developed and maintained by filmsound.ai.

Updates and support: https://filmsound.ai/pt-reaper · info@filmsound.ai
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